Agujero de seguridad en Firefox 3.5: cómo arreglarlo

Se confirmó una grave vulnerabilidad en la última versión del navegador Firefox, la 3.5. El bug, que fue calificado por la empresa de seguridad Secunia como “altamente crítico”, permite acceder a la computadora del usuario del browser. Mientras Mozilla prepara un parche para este grave problema, aquí un truco rápido para arreglarlo.

ACTUALIZACIÓN 17/7: Ya hay una nueva versión de Firefox, la 3.51 con el problema resuelto. Basta con actualizar el navegador.

El agujero de seguridad afecta solo a la versión 3.5 porque se aprovecha del nuevo motor de javascript TraceMonkey, solo presente en este lanzamiento. Las versiones anteriores están a salvo.

Para resolver urgente el “milw0rm exploit code” (tal su nombre) hay que hacer lo siguiente:

1) Escribir en la barra de direcciones about:config

image

2) Si se decide continuar con los cambios, hacer click en el botón ¡Seré cuidadoso, lo prometo! (y ser cuidadoso)

image

3) Al lado de donde dice Filtro:, escribir la palabra jit

image

4) Hacer doble click en javascript.options.jit.content para que cambie a False

image

Con este cambio el Firefox 3.5 debería quedar protegido de ataques mientras aparece una nueva versión.

Link: Firefox 3.5 Vulnerability Confirmed